BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW M5 F90 (2018+) General Forums F90 M5 General Forum    CarPlay - need to set up at every ignition on

Post Reply
 
Thread Tools Search this Thread
      03-29-2020, 09:17 AM   #1
wesleyan92
Second Lieutenant
118
Rep
248
Posts

Drives: 2019 M5 Comp
Join Date: Jul 2016
Location: Dallas TX

iTrader: (0)

Garage List
2019 BMW M5  [0.00]
CarPlay - need to set up at every ignition on

Folks - recently I am having to set up CarPlay at every ignition on. It does not automatically connect. Anyone else having the same issue?

Appreciate any help.
Thank you.
Shariq
Appreciate 0
      03-29-2020, 12:26 PM   #2
pcai
New Member
pcai's Avatar
Canada
5
Rep
13
Posts

Drives: 2019 F90 M5, X5
Join Date: Feb 2020
Location: Canada

iTrader: (0)

Turn WiFi and Bluetooth on (blue icons in the Control Center) on your iPhone before you get in your car for it to automatically connect. If you have your WiFi or Bluetooth on but not searching for new connections (greyed out icons in Control Center), your iPhone won't automatically connect to your car.
Appreciate 0
      03-29-2020, 01:35 PM   #3
LexProf
Enlisted Member
United_States
20
Rep
48
Posts

Drives: 2018 M550i
Join Date: Jun 2008
Location: Oregon

iTrader: (0)

I don't know the solution to this either. Worked flawlessly for me (connected automatically every time) for like the first 18 months I owned the car, then it got weird. For me, it stopped working mostly when I started up the car at home. And I think that is because CarPlay works thru WiFi and my phone was having a hard time disconnecting from my home WiFi and then connecting to my Car Wifi. I feel like things started to get bad after switching to iOs 13. So now, when I leave the house, after I get a couple of hundred yards away, I manually connect the device. I think if you wait a long while it might eventually connect. But of course we need it to connect to use the phone, etc, thru CarPlay. Annoying.
Appreciate 0
      03-29-2020, 04:02 PM   #4
Aronis
Lieutenant Colonel
Aronis's Avatar
1083
Rep
1,877
Posts

Drives: 2018 M5
Join Date: Aug 2016
Location: Binghamton, NY

iTrader: (0)

I have not used CarPlay in the M5, but have it in the Sienna and have not had an issue with it. I am so pissed about the Bluetooth in the M5 that I can just scream. The only Bluetooth music connection that stays connected is iTunes, the rest disconnect. It works fine in the Sienna (2019) and Q7 (2015) so it's a software issue and BMW needs to fix it. And STOP UPDATING every three months and CAUSING disfunction. Friggen Software Engineers like to Tweak stuff that is WORKING. So I am not surprised that CarPlay would act up. This is a BMW vs iPhone Bluetooth issue. I am not asking BMW to cure Covid 19, just make their car connect to the iPhone reliably. End Rant.

Mike
__________________

2018 M5 and 2015 Q7
Appreciate 1
BMWM5NYC369.50

      03-29-2020, 05:52 PM   #5
euro*
.
euro*'s Avatar
Canada
578
Rep
885
Posts

Drives: F90 M5
Join Date: Nov 2012
Location: Toronto, Canada

iTrader: (7)

Mine doesn't work/connect properly only when I come home, park the car and don't lock it. Next time I get into the car and leave, CarPlay doesn't pair automatically.

So for me solution is simple, lock the car every time and then I'm not getting any connection issues.
Appreciate 0
      03-29-2020, 08:01 PM   #6
wesleyan92
Second Lieutenant
118
Rep
248
Posts

Drives: 2019 M5 Comp
Join Date: Jul 2016
Location: Dallas TX

iTrader: (0)

Garage List
2019 BMW M5  [0.00]
Quote:
Originally Posted by LexProf View Post
I don't know the solution to this either. Worked flawlessly for me (connected automatically every time) for like the first 18 months I owned the car, then it got weird. For me, it stopped working mostly when I started up the car at home. And I think that is because CarPlay works thru WiFi and my phone was having a hard time disconnecting from my home WiFi and then connecting to my Car Wifi. I feel like things started to get bad after switching to iOs 13. So now, when I leave the house, after I get a couple of hundred yards away, I manually connect the device. I think if you wait a long while it might eventually connect. But of course we need it to connect to use the phone, etc, thru CarPlay. Annoying.
LexProf - you maybe on to something; that is what is happening with mine as well I bet.

This is super annoying.

Thank you!
Appreciate 0
      03-29-2020, 09:12 PM   #7
Genius
New Member
Genius's Avatar
United_States
3
Rep
20
Posts

Drives: AW E39 M5, F90 M5, E30 M3
Join Date: Apr 2018
Location: Huntington Beach CA

iTrader: (0)

On IOS13 there is a new restriction when connecting to accessories when phone screen is locked. On your phone, go to SETTINGS, then select TOUCH ID &PASSCODE , scroll down to section ALLOW ACCESS WHEN LOCKED, at the bottom of that section is USB ACCESSORIES.... toggle that to on.
That should allow the phone to connect when it’s screen is locked.
I don’t know if that will fix it but it just may be the issue.
Appreciate 0
      03-29-2020, 10:06 PM   #8
modthispny
First Lieutenant
126
Rep
338
Posts

Drives: 2019 BMW M550i
Join Date: Oct 2006
Location: Studio City, CA

iTrader: (0)

Quote:
Originally Posted by Genius View Post
On IOS13 there is a new restriction when connecting to accessories when phone screen is locked. On your phone, go to SETTINGS, then select TOUCH ID &PASSCODE , scroll down to section ALLOW ACCESS WHEN LOCKED, at the bottom of that section is USB ACCESSORIES.... toggle that to on.
That should allow the phone to connect when it's screen is locked.
I don't know if that will fix it but it just may be the issue.
Thank you!!

I have intermittent issues with it not working and having to remove and re-do it all. Hopefully this fixes it!!
Appreciate 0
      03-30-2020, 06:21 AM   #9
wesleyan92
Second Lieutenant
118
Rep
248
Posts

Drives: 2019 M5 Comp
Join Date: Jul 2016
Location: Dallas TX

iTrader: (0)

Garage List
2019 BMW M5  [0.00]
Quote:
Originally Posted by Genius View Post
On IOS13 there is a new restriction when connecting to accessories when phone screen is locked. On your phone, go to SETTINGS, then select TOUCH ID &PASSCODE , scroll down to section ALLOW ACCESS WHEN LOCKED, at the bottom of that section is USB ACCESSORIES.... toggle that to on.
That should allow the phone to connect when itís screen is locked.
I donít know if that will fix it but it just may be the issue.
Thank you! USB was not enabled so I have toggled it on. Fingers crossed.
Appreciate 0
      03-30-2020, 11:56 AM   #10
windtendo
Major
windtendo's Avatar
860
Rep
1,406
Posts

Drives: Nardo F90
Join Date: Apr 2013
Location: Houston

iTrader: (1)

Garage List
2019 BMW M5  [0.00]
Quote:
Originally Posted by Genius View Post
On IOS13 there is a new restriction when connecting to accessories when phone screen is locked. On your phone, go to SETTINGS, then select TOUCH ID &PASSCODE , scroll down to section ALLOW ACCESS WHEN LOCKED, at the bottom of that section is USB ACCESSORIES.... toggle that to on.
That should allow the phone to connect when itís screen is locked.
I donít know if that will fix it but it just may be the issue.
This is for USB accessories, not wireless connections. I believe the purpose of this option getting created was for protection against GrayKey and other equipment used to gain access to someone's phone through a USB connection even when locked.

If anything I'd imagine the phone still being connected to the home/office WiFi when starting up the car would be the culprit.
__________________
IG @windtendo_m5
Appreciate 0
      03-30-2020, 01:11 PM   #11
M3PGH
Major
United_States
357
Rep
1,061
Posts

Drives: Too Many
Join Date: Mar 2009
Location: Pittsburgh,PA

iTrader: (1)

mine was hit and miss so I gave up on it
Appreciate 0
      03-30-2020, 03:05 PM   #12
DallasLife345M
Captain
United_States
478
Rep
739
Posts

Drives: 2018 M3cs
Join Date: Sep 2010
Location: Dallas, TX

iTrader: (0)

I have the exact issue on my M3 CS, it started about a week ago. No fix yet, just very frustrating to forget the device and re-add it every time I get in the car. I noticed that previous time the issue it connected over Bluetooth, now it connects over WiFi. Not sure if that's due to some update or what. But very frustrated about it.
Appreciate 0
      03-30-2020, 04:01 PM   #13
Omar0022
Enlisted Member
28
Rep
30
Posts

Drives: BMW M5 Competition
Join Date: Dec 2019
Location: Seattle

iTrader: (0)

I don't have this issue in my M5C but I do on my Boxster and I've noticed that in that case I have something else connected over Bluetooth, for example AirPods, Apple Watch, etc. once I disconnect that device, it connects to my Boxster just fine. Not sure if that's applicable here but try that and see if it helps. I'm guessing there is still some bugs that Apple needs to work out.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:55 AM.




m5post
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST